Header Ads Widget

O Maah Go, Turu Lob

 Problem:-

Bob's crush's name starts with a vowel. That's the reason Bob loves vowels too much. He calls a string "lovely string" if it contains either all the lowercase vowels or all the uppercase vowels or both, else he calls that string "ugly string". 

For more clarification, see the sample testcase explanation.

Input

First line contains T, the number of test cases.
Next T lines contain a single string S.

Output

For each test case, print "lovely string" or "ugly string"  (without quotes)  according to the definition of Bob.

Constraints

string contains only lowercase and uppercase Latin letters. 

1T100

1len(S)100000

Sample Input
3
omahgoTuRuLob
OmAhgotUrulobEI
aeKORONAoiBATCHu
Sample Output
ugly string
lovely string
lovely string
Time Limit: 1
Memory Limit: 256
Source Limit:
Explanation

In first string, neither all five lowercase vowels are present nor all five uppercase vowels.

In second string, all five uppercase vowels are present.

In third string ,  all five lowercase vowels are present.

Code:-

#include<stdio.h>
int main ()
{
    int n,x,a[91];
    char s[100000];
    
    scanf("%d",&n);
    while(n--)
    {
        for(int i=65;i<=90;i++)
     a[i]=0;
        scanf("%s",s);
for(int i=0;s[i];i++)
        {
            x=s[i];
            if(x>90)
             x=x-32;
            a[x]=1;
            
        }
        if(a[65]==1 && a[69]==1 && a[73]==1 && a[79]==1 && a[85]==1)
         printf("lovely string\n");
        else
         printf("ugly string\n");

    }
    return 0;
}



Post a Comment

0 Comments