Header Ads Widget

Zoos | Hackerearth practice problem solution

  Problem:-

You are required to enter a word that consists of x and y that denote the number of Zs and Os respectively. The input word is considered similar to word zoo if 2×x=y.
Determine if the entered word is similar to word zoo.
For example, words such as zzoooo and zzzoooooo are similar to word zoo but not the words such as zzooo and zzzooooo.
Input format
  • First line: A word that starts with several Zs and continues by several Os.
    Note: The maximum length of this word must be 20.
Output format
Print Yes if the input word can be considered as the string zoo otherwise, print No.
SAMPLE INPUT
 
zzzoooooo
SAMPLE OUTPUT
 
Yes
Explanation
-
Time Limit:0.5 sec(s) for each input file.
Memory Limit:256 MB
Source Limit:1024 KB

Code:-

Solution by ( C language):-

#include<stdio.h>
#include<string.h>
int main()
{
char s[20];
int x,y=0,a=0,i,l;
gets(s);
l=strlen(s);
for(i=0;i<=l-1;i++)
{
x=s[i];
if(x==122)
y++;
else
a++;
}
if(2*y==a)
printf("Yes");
else
printf("No");
return 0;
}


Recommended Post:-



Post a Comment

0 Comments