Program to double the vowel characters in the string :
Given a string , write a program to double the vowel characters in the string .
Sample input :-
Easy
Sample output:-
EEaasy
Program to double the vowel character in the string :-
The objective of the code is to double the vowel characters (a,e,i,o,u ,A, E,I,O,U) in the string .
Code:-
#include<bits/stdc++.h>
using namespace std;
// function to check vowel
int IsVowel(char ch)
{
ch=tolower(ch);
if(ch=='a' || ch=='e' || ch=='i' || ch=='o' || ch=='u')
return 1;
return 0;
}
int main()
{
string str;
char res[1000];
int k=0;
cout<<"Enter the string"<<endl;
cin>>str;
for(int i=0;i<str.size();i++)
{
if(IsVowel(str[i]))
{
res[k++]=str[i];
}
res[k++]=str[i];
}
res[k]='\0';
cout<<"Final string is :"<<endl;
cout<<res;
return 0;
}
Output:-
Enter the string
EasyCodingZone
Final string is :
EEaasyCoodiingZoonee
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Wipro :-
- Update the booking ID | Wipro previous year question paper solution
- Pages in PDF
- Find the location id
- Find the odd digits
- Find the Product ID
Infytq :-
Key Points;-
Hackerrank:-
- Python : missing characters : hackerrank solution
- Python : string transformation | Hackerrank solution
- Active Traders certification test problem | Hackerrank Solution
- Usernames changes certification test problem | Hackerrank Solution
- string Representation of objects certification test hackerrank solution
- Average Function | hackerrank certification problem solution
C-tutorial:-
- Micros in C
- Pointer in c
- Function declaration
- Types of user define function
- return type of function
- 2D array
- c program to convert specified days into years weeks and days
- Print Reverse Hollow Pyramid
- Update the booking ID | Wipro previous year question paper
- Pages in PDF | Wipro previous year question paper
- Sparse Matrix in data structure
- Find the location ID | Wipro previous year Coding question
- find the odd digits | Wipro Coding question
- Find the product id | Wipro Coding question
- Difference between static and dynamic memory allocation
- What is asymptotic Notation
0 Comments