Find the number of pairs in the array whose sum is equal to a given target :-
Given an array of integer and the target value , write a program to Find the number of pairs in the array whose
sum is equal to a given target.
Sample input:
1 5 4 2 6 3 0 76
Sample output:
1 5 4 2 6 3 0 7
6
3
Explanation:- (1,5) (4,2) (6,0) are the pairs whose sum is equal to the target 6 so total 3 pairs are there so output is 3 .
Find the number of pairs in the array whose sum is equal to a given target:-
The objective of the code is to Find the number of pairs in the array whose
sum is equal to a given target.
C++ code:-
#include<bits/stdc++.h>
using namespace std;
// function for finding the pairs
int findpairs(int a[],int target,int n)
{
int count=0;
for(int i=0;i<n;i++)
{
for(int j=i+1;j<n;j++)
{
if((a[i]+a[j])==target)
count++;
}
}
return count;
}
int main()
{
int n,target;
cout<<"Enter the size of the array"<<endl;
cin>>n;
int a[n];
cout<<"Enter the elements of the array"<<endl;
for(int i=0;i<n;i++)
{
cin>>a[i];
}
cout<<"Enter the target value"<<endl;
cin>>target;
cout<<findpairs(a,target,n);
return 0;
}
Output:-
Enter the size of the array
8
Enter the elements of the array
1 5 4 2 6 3 0 7
Enter the target value
6
3
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Wipro :-
- Update the booking ID | Wipro previous year question paper solution
- Pages in PDF
- Find the location id
- Find the odd digits
- Find the Product ID
Infytq :-
Key Points;-
Hackerrank:-
- Python : missing characters : hackerrank solution
- Python : string transformation | Hackerrank solution
- Active Traders certification test problem | Hackerrank Solution
- Usernames changes certification test problem | Hackerrank Solution
- string Representation of objects certification test hackerrank solution
- Average Function | hackerrank certification problem solution
C-tutorial:-
- Micros in C
- Pointer in c
- Function declaration
- Types of user define function
- return type of function
- 2D array
- c program to convert specified days into years weeks and days
- Print Reverse Hollow Pyramid
- Update the booking ID | Wipro previous year question paper
- Pages in PDF | Wipro previous year question paper
- Sparse Matrix in data structure
- Find the location ID | Wipro previous year Coding question
- find the odd digits | Wipro Coding question
- Find the product id | Wipro Coding question
- Difference between static and dynamic memory allocation
- What is asymptotic Notation
0 Comments