Program to check that string containing valid parentheses or not:-
Given a string s
containing just the characters '('
, ')'
, '{'
, '}'
, '['
and ']'
, write a Program to check that string containing valid parentheses or not .
An input string is valid if:
- Open brackets must be closed by the same type of brackets.
- Open brackets must be closed in the correct order.
- Every close bracket has a corresponding open bracket of the same type.
Sample input:-
()[]{}
Sample output:-
Valid
Program to check that string containing valid parentheses or not:-
The objective of code is to check that the given string containing the valid parentheses or not.
Code:-
#include<bits/stdc++.h>
using namespace std;
bool isValid(string s) {
char stack[5000];
int top=-1;
for(int i=0;i<s.size();i++)
{
if(s[i]=='(' || s[i]=='{' || s[i]=='[')
stack[++top]=s[i];
else
{
if(top<0)
return false;
if(s[i]==')')
{
if(stack[top]!='(')
return false;
top--;
}
if(s[i]=='}')
{
if(stack[top]!='{')
return false;
top--;
}
if(s[i]==']')
{
if(stack[top]!='[')
return false;
top--;
}
}
}
if(top==-1)
return true;
return false;
}
int main()
{
string str;
cout<<"Enter a string"<<endl;
cin>>str;
if(isValid(str)==true)
cout<<"Valid"<<endl;
else
cout<<"Not valid"<<endl;
}
Output:-
Enter a string
[{()}][]
Valid
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Wipro :-
- Update the booking ID | Wipro previous year question paper solution
- Pages in PDF
- Find the location id
- Find the odd digits
- Find the Product ID
Infytq :-
Key Points;-
Hackerrank:-
- Python : missing characters : hackerrank solution
- Python : string transformation | Hackerrank solution
- Active Traders certification test problem | Hackerrank Solution
- Usernames changes certification test problem | Hackerrank Solution
- string Representation of objects certification test hackerrank solution
- Average Function | hackerrank certification problem solution
C-tutorial:-
- Micros in C
- Pointer in c
- Function declaration
- Types of user define function
- return type of function
- 2D array
- c program to convert specified days into years weeks and days
- Print Reverse Hollow Pyramid
- Update the booking ID | Wipro previous year question paper
- Pages in PDF | Wipro previous year question paper
- Sparse Matrix in data structure
- Find the location ID | Wipro previous year Coding question
- find the odd digits | Wipro Coding question
- Find the product id | Wipro Coding question
- Difference between static and dynamic memory allocation
- What is asymptotic Notation
0 Comments