Program to Swap the adjacent characters of the string :-
Given a string , swap the adjacent characters of the string .
Sample input:-
EasyCodingZone
Sample output:-
Enter the string
EasyCodingZone
String after Swapping the characters :
aEysoCidgnoZen
Program to Swap the adjacent characters of the string .
The objective of the code is to swap the adjacent character of the string . But if the length of the string is odd then it is not possible to swap the all the characters .
Code:-
#include<bits/stdc++.h>
using namespace std;
int main()
{
string str;
cout<<"Enter the string"<<endl;
cin>>str;
int length=str.size();
// if length is odd then it is not possible
// to swap the characters
if(length%2!=0)
cout<<"Swapping is not possible"<<endl;
else
{
for(int i=0;i<length-1;i=i+2)
{
char tem;
tem=str[i];
str[i]=str[i+1];
str[i+1]=tem;
}
cout<<"String after Swapping the characters : "<<endl;
cout<<str;
}
return 0;
}
Output:-
Enter the string
EasyCodingZone
String after Swapping the characters :
aEysoCidgnoZen
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Wipro :-
- Update the booking ID | Wipro previous year question paper solution
- Pages in PDF
- Find the location id
- Find the odd digits
- Find the Product ID
Infytq :-
Key Points;-
Hackerrank:-
- Python : missing characters : hackerrank solution
- Python : string transformation | Hackerrank solution
- Active Traders certification test problem | Hackerrank Solution
- Usernames changes certification test problem | Hackerrank Solution
- string Representation of objects certification test hackerrank solution
- Average Function | hackerrank certification problem solution
C-tutorial:-
- Micros in C
- Pointer in c
- Function declaration
- Types of user define function
- return type of function
- 2D array
- c program to convert specified days into years weeks and days
- Print Reverse Hollow Pyramid
- Update the booking ID | Wipro previous year question paper
- Pages in PDF | Wipro previous year question paper
- Sparse Matrix in data structure
- Find the location ID | Wipro previous year Coding question
- find the odd digits | Wipro Coding question
- Find the product id | Wipro Coding question
- Difference between static and dynamic memory allocation
- What is asymptotic Notation
0 Comments