Program to print the characters with their frequency :-
Given a string , write a Program to print the characters with their frequency .
Sample input:-
easycodingzone
Sample output:-
1a1c1d2e1g1i2n2o1s1y1z
Program to print the characters with their frequency
The objective of the code is to print the characters with their frequency .
Code:-
#include<bits/stdc++.h>
using namespace std;
int main()
{
string str;
cout<<"Enter a string"<<endl;
cin>>str;
map<char,int> m;
for(int i=0;i<str.size();i++)
{
m[str[i]]++;
}
for(auto ch:m)
{
cout<<ch.second<<ch.first;
}
return 0;
}
Output:-
Enter a string
easycodingzone
1a1c1d2e1g1i2n2o1s1y1z
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Wipro :-
- Update the booking ID | Wipro previous year question paper solution
- Pages in PDF
- Find the location id
- Find the odd digits
- Find the Product ID
Infytq :-
Key Points;-
Hackerrank:-
- Python : missing characters : hackerrank solution
- Python : string transformation | Hackerrank solution
- Active Traders certification test problem | Hackerrank Solution
- Usernames changes certification test problem | Hackerrank Solution
- string Representation of objects certification test hackerrank solution
- Average Function | hackerrank certification problem solution
C-tutorial:-
- Micros in C
- Pointer in c
- Function declaration
- Types of user define function
- return type of function
- 2D array
- c program to convert specified days into years weeks and days
- Print Reverse Hollow Pyramid
- Update the booking ID | Wipro previous year question paper
- Pages in PDF | Wipro previous year question paper
- Sparse Matrix in data structure
- Find the location ID | Wipro previous year Coding question
- find the odd digits | Wipro Coding question
- Find the product id | Wipro Coding question
- Difference between static and dynamic memory allocation
- What is asymptotic Notation
0 Comments