C program to construct a Fibonacci series up to n terms
Given a number n , write a program to construct a Fibonacci series up to n terms . So first we have to know what is Fibonacci series .
what is fibonacci series:-
In the Fibonacci series every elements are the some of two elements before it.
Fibonacci Sequence = 0, 1, 1, 2, 3, 5, 8, 13, 21, ….
Sample input
6
Sample output
0 1 1 2 3 5
C program to construct a Fibonacci series up to n terms
The objective of the code is to construct a Fibonacci series up to given number of terms .
Code(C):-
#include<stdio.h>
#include<conio.h>
int main()
{
int n,pp=0,p=1,nx,i; //pp=previous previous term
// p=previous term,nx=next term
printf("Enter the nunber of term in fibonacci series\n");
scanf("%d",&n);
printf("%d %d ",pp,p);
for(i=2;i<n;i++)
{
nx=pp+p;
printf("%d ",nx);
pp=p;
p=nx;
}
return 0;
}
Output:
Enter the number of term in Fibonacci series
6
0 1 1 2 3 5
Recommended Post :-
HCL Coding Questions:-
Capgemini Coding Questions:-
iMocha coding Questions:-
Tech Mahindra coding questions:-
Unthinkable Solutions coding questions:-
- Swap the adjacent characters of the string
- Double the vowel characters in the string
- Character with their frequency
- Program to find the closest value
Must check this:-
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Full C course:-
Key points:-
- How to set limit in the floating value in python
- What is boolean data type
- How to print any character without using format specifier
- How to check that given number is power of 2 or not
- How to fix limit in double and floating numbers after dot (.) in c++
- How to print a double or floating point number in scientific notation and fixed notation
- How to take input a string in c
- How to reduce the execution time of program in c++.
Cracking the coding interview:-
Array and string:-
Tree and graph:-
Hackerearth Problems:-
- Very Cool numbers | Hacker earth solution
- Vowel Recognition | Hackerearth practice problem solution
- Birthday party | Hacker earth solution
- Most frequent | hacker earth problem solution
- program to find symetric difference of two sets
- cost of balloons | Hacker earth problem solution
- Chacha o chacha | hacker earth problem solution
- jadu and dna | hacker earth solution
- Bricks game | hacker earth problem
- Anti-Palindrome strings | hacker earth solution
- connected components in the graph | hacker earth data structure
- odd one out || hacker earth problem solution
- Minimum addition | Hackerearth Practice problem
- The magical mountain | Hackerearth Practice problem
- The first overtake | Hackerearth Practice problem
Hackerrank Problems:-
- Playing With Characters | Hackerrank practice problem solution
- Sum and Difference of Two Numbers | hackerrank practice problem solution
- Functions in C | hackerrank practice problem solution
- Pointers in C | hackerrank practice problem solution
- Conditional Statements in C | Hackerrank practice problem solution
- For Loop in C | hackerrank practice problem solution
- Sum of Digits of a Five Digit Number | hackerrank practice problem solution
- 1D Arrays in C | hackerrank practice problem solution
- Array Reversal | hackerrank practice problem solution
- Printing Tokens | hackerrank practice problem solution
- Digit Frequency | hackerrank practice problem solution
- Calculate the Nth term | hackerrank practice problem solution
Data structure:-
- Program to find cycle in the graph
- Implementation of singly link list
- Implementation of queue by using link list
- Algorithm of quick sort
- stack by using link list
- program to find preorder post order and inorder of the binary search tree
- Minimum weight of spanning tree
- Preorder, inorder and post order traversal of the tree
MCQs:-
4 Comments
Good work
ReplyDelete👍👍👍👍👍👍👍👍
ReplyDelete,👌👌👌👌
ReplyDeleteThanks sir it is easy to understand
ReplyDelete