Write a C program to receive a five-digit no and display as like 24689: 2 4 6 8 9
Given a five digit number , write a program to receive a five-digit no and display as like 24689: 2 4 6 8 9 .
Sample input
24986
Sample output
6 8 9 4 2
Write a C program to receive a five-digit no and display as like 24689: 2 4 6 8 9
The objective of the code is to print the digits of the number by space separated .
Algorithm:
- Take input a 5-digit number from the user using scanf().
- Initialize a loop counter variable to 0.
- Divide the input number by 10 and store the remainder in a variable. This will give the last digit of the number.
- Print the last digit, followed by two spaces.
- Divide the input number by 10 and store the quotient in the input number variable.
- Increment the loop counter variable.
- Repeat steps 3 to 6 until the loop counter variable is less than 5.
Code(C):-
##include<stdio.h>
int main()
{
int num, remainder, i;
printf("Enter a five-digit number: ");
scanf("%d", &num);
printf("%d: ", num);
for (i = 0; i < 5; i++)
{
remainder = num % 10;
printf(" %d ", remainder);
num = num / 10;
}
return 0;
}
Output:
Enter a five-digit number: 24986:
6 8 9 4 2
Explanation:
- The program starts by taking input from the user using the scanf() function and storing it in the variable num.
- The program then prints the input number along with a colon and two spaces using the printf() function.
- The program then initializes a loop counter variable to 0.
- The program then divides the input number by 10 and stores the remainder in the variable remainder. This gives the last digit of the number.
- The program then prints the last digit, followed by two spaces, using the printf() function.
- The program then divides the input number by 10 and stores the quotient back in the input number variable.
- The program then increments the loop counter variable.
- Steps 4 to 7 are repeated until the loop counter variable is less than 5, which means that all digits have been printed.
Recommended Post :-
HCL Coding Questions:-
Capgemini Coding Questions:-
iMocha coding Questions:-
Tech Mahindra coding questions:-
Unthinkable Solutions coding questions:-
- Swap the adjacent characters of the string
- Double the vowel characters in the string
- Character with their frequency
- Program to find the closest value
Must check this:-
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Full C course:-
Key points:-
- How to set limit in the floating value in python
- What is boolean data type
- How to print any character without using format specifier
- How to check that given number is power of 2 or not
- How to fix limit in double and floating numbers after dot (.) in c++
- How to print a double or floating point number in scientific notation and fixed notation
- How to take input a string in c
- How to reduce the execution time of program in c++.
Cracking the coding interview:-
Array and string:-
Tree and graph:-
Hackerearth Problems:-
- Very Cool numbers | Hacker earth solution
- Vowel Recognition | Hackerearth practice problem solution
- Birthday party | Hacker earth solution
- Most frequent | hacker earth problem solution
- program to find symetric difference of two sets
- cost of balloons | Hacker earth problem solution
- Chacha o chacha | hacker earth problem solution
- jadu and dna | hacker earth solution
- Bricks game | hacker earth problem
- Anti-Palindrome strings | hacker earth solution
- connected components in the graph | hacker earth data structure
- odd one out || hacker earth problem solution
- Minimum addition | Hackerearth Practice problem
- The magical mountain | Hackerearth Practice problem
- The first overtake | Hackerearth Practice problem
Hackerrank Problems:-
- Playing With Characters | Hackerrank practice problem solution
- Sum and Difference of Two Numbers | hackerrank practice problem solution
- Functions in C | hackerrank practice problem solution
- Pointers in C | hackerrank practice problem solution
- Conditional Statements in C | Hackerrank practice problem solution
- For Loop in C | hackerrank practice problem solution
- Sum of Digits of a Five Digit Number | hackerrank practice problem solution
- 1D Arrays in C | hackerrank practice problem solution
- Array Reversal | hackerrank practice problem solution
- Printing Tokens | hackerrank practice problem solution
- Digit Frequency | hackerrank practice problem solution
- Calculate the Nth term | hackerrank practice problem solution
Data structure:-
- Program to find cycle in the graph
- Implementation of singly link list
- Implementation of queue by using link list
- Algorithm of quick sort
- stack by using link list
- program to find preorder post order and inorder of the binary search tree
- Minimum weight of spanning tree
- Preorder, inorder and post order traversal of the tree
MCQs:-
0 Comments