C program to check whether a character is uppercase or lowercase alphabet
Given a character , write a program to check whether it is uppercase or lowercase .
Method 1: By using standard function ( isupper() and islower() ) .
Method 2: By Checking range i.e ( if Character is in range A to Z then uppercase ).
Method 3: By using Ascii values . (Ascii of A to Z is 65 to 90 and Ascii value of a to z is 97 to 122 )
Sample input
A
Sample output
A is Uppercase
C program to check whether a character is uppercase or lowercase alphabet
The objective of the code is to check whether it is uppercase or lowercase alphabet .
Method 1:
#include<stdio.h>
int main()
{
char ch;
scanf("%c",&ch);
if(isupper(ch))
printf("%c is Uppercase",ch);
else if(islower(ch))
printf("%c is Lowercase",ch);
else
printf("Invalid input");
return 0;
}
Output:-
A
A is Uppercase
Method 2:
#include<stdio.h>
int main()
{
char ch;
scanf("%c",&ch);
if(ch>='A' && ch<='Z')
printf("%c is Uppercase",ch);
else if(ch>='a' && ch<='z')
printf("%c is Lowercase",ch);
else
printf("Invalid input");
return 0;
}
Output:-
A
A is Uppercase
Method 3 : (By using Ascii value)
#include<stdio.h>
int main()
{
char ch;
int a;
scanf("%c",&ch);
// converting character into
// integer i.e Ascii value
a=ch;
if(a>=65 && a<=90)
printf("%c is Uppercase",ch);
else if(a>=97 && a<=122)
printf("%c is Lowercase",ch);
else
printf("Invalid input");
return 0;
}
Output:-
A
A is Uppercase
Recommended Post :-
HCL Coding Questions:-
Capgemini Coding Questions:-
iMocha coding Questions:-
Tech Mahindra coding questions:-
Unthinkable Solutions coding questions:-
- Swap the adjacent characters of the string
- Double the vowel characters in the string
- Character with their frequency
- Program to find the closest value
Must check this:-
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Full C course:-
Key points:-
- How to set limit in the floating value in python
- What is boolean data type
- How to print any character without using format specifier
- How to check that given number is power of 2 or not
- How to fix limit in double and floating numbers after dot (.) in c++
- How to print a double or floating point number in scientific notation and fixed notation
- How to take input a string in c
- How to reduce the execution time of program in c++.
Cracking the coding interview:-
Array and string:-
Tree and graph:-
Hackerearth Problems:-
- Very Cool numbers | Hacker earth solution
- Vowel Recognition | Hackerearth practice problem solution
- Birthday party | Hacker earth solution
- Most frequent | hacker earth problem solution
- program to find symetric difference of two sets
- cost of balloons | Hacker earth problem solution
- Chacha o chacha | hacker earth problem solution
- jadu and dna | hacker earth solution
- Bricks game | hacker earth problem
- Anti-Palindrome strings | hacker earth solution
- connected components in the graph | hacker earth data structure
- odd one out || hacker earth problem solution
- Minimum addition | Hackerearth Practice problem
- The magical mountain | Hackerearth Practice problem
- The first overtake | Hackerearth Practice problem
Hackerrank Problems:-
- Playing With Characters | Hackerrank practice problem solution
- Sum and Difference of Two Numbers | hackerrank practice problem solution
- Functions in C | hackerrank practice problem solution
- Pointers in C | hackerrank practice problem solution
- Conditional Statements in C | Hackerrank practice problem solution
- For Loop in C | hackerrank practice problem solution
- Sum of Digits of a Five Digit Number | hackerrank practice problem solution
- 1D Arrays in C | hackerrank practice problem solution
- Array Reversal | hackerrank practice problem solution
- Printing Tokens | hackerrank practice problem solution
- Digit Frequency | hackerrank practice problem solution
- Calculate the Nth term | hackerrank practice problem solution
Data structure:-
- Program to find cycle in the graph
- Implementation of singly link list
- Implementation of queue by using link list
- Algorithm of quick sort
- stack by using link list
- program to find preorder post order and inorder of the binary search tree
- Minimum weight of spanning tree
- Preorder, inorder and post order traversal of the tree
MCQs:-
0 Comments