Write a function that return sum of all the odd digits of a given positive no entered through keyboard in c++
Given a number , write a function that return sum of all the odd digits of a given positive no entered through keyboard in c++ .
Sample input
4567
Sample Output:
Sum of odd digits of 4567 is: 12
Write a function that return sum of all the odd digits of a given positive no entered through keyboard in c++
The objective of the code is to write a function that return sum of all the odd digits of a given positive number entered by the user .
Algorithm:-
- Define a function called
sumOddDigits
which takes a positive integer as its argument. - Initialize a variable called
sum
to zero. - While the given positive integer is greater than zero:
a. Extract the last digit of the integer using the modulus operator (%).
b. Check if the extracted digit is odd or not using the modulus operator (%).
c. If the digit is odd, add it to the
sum
variable. d. Divide the integer by 10 to remove the last digit. - Return the final
sum
variable.
Code(C++):-
#include <iostream>
using namespace std;
int sumOddDigits(int n) {
int sum = 0;
while (n > 0) {
int digit = n % 10;
if (digit % 2 != 0) {
sum += digit;
}
n /= 10;
}
return sum;
}
int main() {
int num;
cout << "Enter a positive integer: ";
cin >> num;
cout << "Sum of odd digits of " << num << " is: " << sumOddDigits(num) << endl;
return 0;
}
Output:-
Enter a positive integer: 4567
Sum of odd digits of 4567 is: 12
Recommended Post :-
HCL Coding Questions:-
Capgemini Coding Questions:-
iMocha coding Questions:-
Tech Mahindra coding questions:-
Unthinkable Solutions coding questions:-
- Swap the adjacent characters of the string
- Double the vowel characters in the string
- Character with their frequency
- Program to find the closest value
Must check this:-
Companies interview:-
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Full C course:-
Key points:-
- How to set limit in the floating value in python
- What is boolean data type
- How to print any character without using format specifier
- How to check that given number is power of 2 or not
- How to fix limit in double and floating numbers after dot (.) in c++
- How to print a double or floating point number in scientific notation and fixed notation
- How to take input a string in c
- How to reduce the execution time of program in c++.
Cracking the coding interview:-
Array and string:-
Tree and graph:-
Hackerearth Problems:-
- Very Cool numbers | Hacker earth solution
- Vowel Recognition | Hackerearth practice problem solution
- Birthday party | Hacker earth solution
- Most frequent | hacker earth problem solution
- program to find symetric difference of two sets
- cost of balloons | Hacker earth problem solution
- Chacha o chacha | hacker earth problem solution
- jadu and dna | hacker earth solution
- Bricks game | hacker earth problem
- Anti-Palindrome strings | hacker earth solution
- connected components in the graph | hacker earth data structure
- odd one out || hacker earth problem solution
- Minimum addition | Hackerearth Practice problem
- The magical mountain | Hackerearth Practice problem
- The first overtake | Hackerearth Practice problem
Hackerrank Problems:-
- Playing With Characters | Hackerrank practice problem solution
- Sum and Difference of Two Numbers | hackerrank practice problem solution
- Functions in C | hackerrank practice problem solution
- Pointers in C | hackerrank practice problem solution
- Conditional Statements in C | Hackerrank practice problem solution
- For Loop in C | hackerrank practice problem solution
- Sum of Digits of a Five Digit Number | hackerrank practice problem solution
- 1D Arrays in C | hackerrank practice problem solution
- Array Reversal | hackerrank practice problem solution
- Printing Tokens | hackerrank practice problem solution
- Digit Frequency | hackerrank practice problem solution
- Calculate the Nth term | hackerrank practice problem solution
Data structure:-
- Program to find cycle in the graph
- Implementation of singly link list
- Implementation of queue by using link list
- Algorithm of quick sort
- stack by using link list
- program to find preorder post order and inorder of the binary search tree
- Minimum weight of spanning tree
- Preorder, inorder and post order traversal of the tree
MCQs:-
0 Comments