Write a Python program to print area of rectangle using function & return its value to main function
Given length and width of the rectangle , write a Python program to print area of rectangle using function & return its value to main function .
Sample input
4
3
Sample output
The area of the rectangle is: 12
Write a Python program to print area of rectangle using function & return its value to main function
The objective of the code is to find the area of the rectangle and return it to the main function that is driver function of the code .
Algorithm:
- Start the program.
- Define the
area()
function with two argumentslength
andwidth
. - Inside the
area()
function, multiply the length and width of the rectangle and return the product as the area of the rectangle. - In the main program, ask the user to input the length and width of the rectangle using
input()
function and store them in variablesl
andw
. - Call the
area()
function with argumentsl
andw
and store the returned value in a variablea
. - Print the area of the rectangle using
print()
function. - End the program.
Code(Python):-
def area(length, width): return length * width
if __name__ == '__main__': l = int(input("Enter length of rectangle: ")) w = int(input("Enter width of rectangle: ")) a = area(l, w) print(f"The area of the rectangle is: {a}")
Output:
Enter length of rectangle: 4Enter width of rectangle: 3The area of the rectangle is: 12
Explanation
In this program, the area()
function takes two arguments length
and width
and returns their product as the area of the rectangle. The main program asks the user to input the length and width of the rectangle using input()
function and stores them in variables l
and w
. It then calls the area()
function with arguments l
and w
and stores the returned value in a variable a
. Finally, it prints the area of the rectangle using print()
function.
Recommended Post :-
HCL Coding Questions:-
- Swap the adjacent characters of the string
- Double the vowel characters in the string
- Character with their frequency
- Program to find the closest value
- Swap adjacent characters
- Double the vowel characters
- Check valid parenthesis
- Print the characters with their frequencies
- Find closest value
- Word Count
- Program of CaesarCipher
- Program to find the perfect city
- Annual Day | Tech Mahindra coding question
- Find the number of pairs in the array whose sum is equal to a given target.
Full C course:-
Key points:-
- How to set limit in the floating value in python
- What is boolean data type
- How to print any character without using format specifier
- How to check that given number is power of 2 or not
- How to fix limit in double and floating numbers after dot (.) in c++
- How to print a double or floating point number in scientific notation and fixed notation
- How to take input a string in c
- How to reduce the execution time of program in c++.
Cracking the coding interview:-
Array and string:-
Tree and graph:-
Hackerearth Problems:-
- Very Cool numbers | Hacker earth solution
- Vowel Recognition | Hackerearth practice problem solution
- Birthday party | Hacker earth solution
- Most frequent | hacker earth problem solution
- program to find symetric difference of two sets
- cost of balloons | Hacker earth problem solution
- Chacha o chacha | hacker earth problem solution
- jadu and dna | hacker earth solution
- Bricks game | hacker earth problem
- Anti-Palindrome strings | hacker earth solution
- connected components in the graph | hacker earth data structure
- odd one out || hacker earth problem solution
- Minimum addition | Hackerearth Practice problem
- The magical mountain | Hackerearth Practice problem
- The first overtake | Hackerearth Practice problem
- Playing With Characters | Hackerrank practice problem solution
- Sum and Difference of Two Numbers | hackerrank practice problem solution
- Functions in C | hackerrank practice problem solution
- Pointers in C | hackerrank practice problem solution
- Conditional Statements in C | Hackerrank practice problem solution
- For Loop in C | hackerrank practice problem solution
- Sum of Digits of a Five Digit Number | hackerrank practice problem solution
- 1D Arrays in C | hackerrank practice problem solution
- Array Reversal | hackerrank practice problem solution
- Printing Tokens | hackerrank practice problem solution
- Digit Frequency | hackerrank practice problem solution
- Calculate the Nth term | hackerrank practice problem solution
Data structure:-
- Program to find cycle in the graph
- Implementation of singly link list
- Implementation of queue by using link list
- Algorithm of quick sort
- stack by using link list
- program to find preorder post order and inorder of the binary search tree
- Minimum weight of spanning tree
- Preorder, inorder and post order traversal of the tree
MCQs:-
0 Comments