Header Ads Widget

C++ Program to check whether a number is Armstrong or not

 

C++ Program to check whether a number is Armstrong or not

Given a number , write a program to check that given number is Armstrong or not . So for that first we have to know that what is Armstrong number .

What is Armstrong number:-  Click here   

Sample input
153
Sample output
Armstrong number 

C++ Program to check whether a number is Armstrong or not

The objective of the code is to check whether a number is Armstrong or not .

Code(C++):-

#include <iostream>
using namespace std;
int main()
{
int n,n1,n2,r,s=1,sum=0; //r=reminder
cout<<"Enter a number";
cin>>n;
n1=n;
n2=n;
while(n!=0)
{
r=n%10;
n=n/10;
while(n1!=0)
{
s=s*r;
n1=n1/10;
}
sum=sum+s;
s=1;
n1=n2;
}
if(sum==n2)
cout<<"number is Armstrong";
else
cout<<"number is not Armstrong";
return 0;
}

Output:-

Enter a number
153
number is Armstrong




Recommended Post :-

HCL Coding Questions:-

Capgemini Coding Questions:-

Companies interview:-

Full C course:-    

Key points:-

Cracking the coding interview:-

 Array and string:-

Tree and graph:-

Hackerearth Problems:-

Hackerrank Problems:-

Data structure:-

 MCQs:-